Tuesday, October 25, 2011

Installing Android Development Tools (ADT) in Eclipse Error

If you are trying to install the Android SDK, specifically the ADT in Eclipse (especially Eclipse on Linux installed via a package manager) and during the installation it says:  

The operation cannot be completed.  See the details.

Cannot complete the install because one or more required items could not be found.
Software being installed: Android Development Tools 14.0.0.v201110171935-205994 (com.android.ide.eclipse.adt.feature.group 14.0.0.v201110171935-205994)
Missing requirement: Android Development Tools 14.0.0.v201110171935-205994 (com.android.ide.eclipse.adt.feature.group 14.0.0.v201110171935-205994) requires 'org.eclipse.wst.sse.core 0.0.0' but it could not be found



Then here is the solution:

1) In Eclipse, go to "Help" then choose "Install New Software..."

2) Click on "Add" and add the following according to your Eclipse version:

Eclipse Indigo (3.7):
Name: Indigo
Location: http://download.eclipse.org/releases/indigo/

Eclipse Helios (3.6):
Name: Helios
Location: http://download.eclipse.org/releases/helios/

Eclipse Galileo (3.5):
Name: Galileo
Location: http://download.eclipse.org/releases/galileo/

Eclipse Ganymede (3.4):
Name: Ganymede
Location: http://download.eclipse.org/releases/ganymede/

3) Press "ok"

4) Then in "Work with" select the ADT Plugin that you added earlier

5) Tick/check the "Developer Tools" checkbox and make sure that the "Contact all update sites during install to find required software" at the bottom of the dialog is also checked/ticked

6) Press "next"

Your ADT should now show no error. Let me know if this solution worked for you! :)

17 comments:

  1. Thanks got fixed !

    Regards,
    Durga charan ojha

    ReplyDelete
    Replies
    1. Great to hear that it was helpful Durga! And thanks for your feedback! It is really appreciated! :)

      Delete
  2. Hello
    My name is jose, I'm from Colombia, your excellent contribution this saved my life.

    thank you very much.

    ReplyDelete
    Replies
    1. Hello Jose,
      Thank you so much for your feedback! I'm so glad that it helped! :)

      Delete
  3. Thanks for sharing your info. I really appreciate your efforts and I will be waiting for your further write ups thanks once again.
    SEO tools

    ReplyDelete
  4. Ok. That was a brilliant fix. Don't know how it worked. But real glad you wrote this post!!!

    ReplyDelete
    Replies
    1. Thanks a lot Yeshwanth! Glad it worked and thanks for your feedback! :)

      Delete
  5. Hi, probably our entry may be off topic but anyways, I have been surfing around your blog and it looks

    very professional. It’s obvious you know your topic and you appear fervent about it. I’m developing a

    fresh blog plus I’m struggling to make it look good, as well as offer the best quality content. I have

    learned much at your web site and also I anticipate alot more articles and will be coming back soon.Thanks you.


    Android App Development

    ReplyDelete
  6. Good Job! Tons of thanks. Worked like a charm.

    ReplyDelete
  7. You are giving great solutions but still i am getting problem to install ADT plugin.. The same error in my eclipse above mentioned..
    so plz help me

    Thanks in advance

    ReplyDelete
  8. Wow, your article helped me resolved my problem. Thank you very much!

    ReplyDelete
  9. Thanks...but for me solution is not worked.

    I wanted install android plugin on eclipse 3.5 32 bit on windows 8 OS.

    ReplyDelete
  10. Thank you mate, really help with similar problem.
    Had problem with installing Google App Engine Plugin

    ReplyDelete
  11. Thanks for the post!!
    Pls help, I have eclipse 3.8 ,want link should I use for it .
    Thanks in adavance :)

    ReplyDelete